The Electra Forums

Guitar Talk about Electra and other vintage imported guitars
Home
Index of Models
The Electra Forums
PM Inbox
It is currently Mon Oct 16, 2017 4:33 pm

All times are UTC - 8 hours




Post new topic Reply to topic  [ 7 posts ] 
Author Message
PostPosted: Wed Feb 06, 2008 7:37 am 
Offline

Joined: Tue Jan 16, 2007 7:58 am
Posts: 142
Should I post them. Cavity's, back of pickups, stuff like that.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Feb 06, 2008 8:05 am 
Offline

Joined: Tue Jan 16, 2007 7:58 am
Posts: 142
Image
Image
Image
Image
Image


Top
 Profile  
 
PostPosted: Tue Aug 24, 2010 9:40 am 
Offline

Joined: Tue Jul 27, 2010 6:42 am
Posts: 17
I'm a new member to the forum and an currently restoring an Omega X-230. I know this is an old post but it has a pic. that relates to a question I have. Somewhere along the line my X-230 had the volume pot replaced with an old pot of the wrong type. The guitar pick-up settings do not work properly and some not at all. I replaced the pot with a new 500k and wired it up like a standard les paul vol. /tone. It's better but still not right. I noticed on the top pic. of this post that there is a small (resistor?) on the vol. pot. It goes from the center lug to grnd. This was missing from my X-230. If I had'nt seen this pic. I would never have known and would forever have been wondering why my guitar won't work. Does anybody know what value this resistor (if it is a resistor) is? Any idea where I can find one? Thanks in advance and I hope someone sees this.


Top
 Profile  
 
PostPosted: Tue Aug 24, 2010 11:29 am 
Offline
User avatar

Joined: Thu Feb 07, 2008 5:52 am
Posts: 1924
Location: Ann Arbor, Michigan
I think the resistor on the volume pot is just a treble bleed circuit (helps to keep signal bright when you turn the volume pot down), although I'm not certain. Could you give us more specific info as far as "The guitar pick-up settings do not work properly"? I have a feeling there is more up here than just a missing resistor, but we can try to help you troubleshoot it.

_________________
Electra Guitar Videos ===> http://www.youtube.com/user/mjm33mjm?feature=watch


Top
 Profile  
 
PostPosted: Tue Aug 24, 2010 12:30 pm 
Offline

Joined: Tue Jul 27, 2010 6:42 am
Posts: 17
So you don't think that resistor would make a lot of difference in pickup vol.? The bridge pick up seems to be ok but neck pickup is very weak or not working. All the wiring looks to be original except for the vol. pot. but I've left the 5-way switch alone (meaning I hav'nt pulled it out to inspect) I'm @ work now so Let me do some poking around inside there with my ohm meter when I get home. I don't want to waist your time. Might be a bad connection somewhere. Thank you


Top
 Profile  
 
PostPosted: Tue Aug 24, 2010 8:13 pm 
Offline
User avatar

Joined: Sun Mar 12, 2006 9:00 pm
Posts: 265
Location: Iowa, USA
daved wrote:
So you don't think that resistor would make a lot of difference in pickup vol.? The bridge pick up seems to be ok but neck pickup is very weak or not working.


The missing resistor isn't helping in any way, but what you describe sounds like a switching problem to me. Then again, I'm not sure on an Omega what the switches in the pot cavity do, if it has the 5-way on the bout. Hafta ask the experts......who will be rolling along here anytime now......

:D

Keep asking questions, btw. We love to talk about this stuff!


Top
 Profile  
 
PostPosted: Tue Sep 07, 2010 6:48 am 
Offline

Joined: Tue Jul 27, 2010 6:42 am
Posts: 17
just to follow up, I had vol. and tone pots wired wrong. Also, It works fine without the resistor. Thanks for the help.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC - 8 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Fatal: Not able to open ./cache/data_global.php