The Electra Forums

Guitar Talk about Electra and other vintage imported guitars
Home
Index of Models
The Electra Forums
PM Inbox
It is currently Fri Dec 15, 2017 4:20 am

All times are UTC - 8 hours




Post new topic Reply to topic  [ 34 posts ]  Go to page Previous  1, 2, 3
Author Message
PostPosted: Mon Feb 21, 2011 10:30 pm 
Offline
User avatar

Joined: Tue Dec 21, 2004 6:30 pm
Posts: 1765
Location: Central Iowa
it's a 5 speed. 159k, from TX and CA so no rust...
had slight hit in front previously, so bumper cover and left fender are replaced/repainted...

_________________
My Electra Pages
I have too many projects!


Top
 Profile  
 
PostPosted: Tue Feb 22, 2011 8:20 am 
Offline

Joined: Wed Feb 11, 2009 1:50 pm
Posts: 431
Location: Saint Louis
mcbrat wrote:
it's a 5 speed. 159k, from TX and CA so no rust...
had slight hit in front previously, so bumper cover and left fender are replaced/repainted...


Awesome! Hope you got a great deal on it.

My Sport Sedan has been great on STi suspension, upgraded front and rear sway bars, plus optimized alignment.

The wagon is due for a suspension update, and I'm trying to choose a reasonable strut solution. The wagon also needs 100k miles maintenance (timing belt, tensioner, water pump, fluids, etc.) as soon as the weather makes it somewhat comfortable to work in my carport.

Wish I had more time and money for car toys.


Top
 Profile  
 
PostPosted: Thu Mar 17, 2011 5:03 am 
Offline
User avatar

Joined: Tue Dec 21, 2004 6:30 pm
Posts: 1765
Location: Central Iowa
well, it's been a nicely trouble free first 1000 miles... though it does seem to have developed a pretty good oil leak... one of the PCV tubes has a crack at the base (drivers side vc) got a new one coming to fix that, but haven't gotten under it yet to really see where it's coming from....

it is however an absolute blast to drive...

I've accumulated some things to put on it when I can make the time...

boost gauge
A/F meter
oil pressure gauge
pillar pod (but since the CD player is crapped out, I'm gonna replace it with a single DIN unit, and put the guages below... though there's still more gauges I want to add... I hate the lack of gauges...

I found a good mug to replace the silencer, but I want to get my gauges in first before I start tweaking stuff :)

_________________
My Electra Pages
I have too many projects!


Top
 Profile  
 
PostPosted: Thu Mar 17, 2011 11:08 am 
Offline

Joined: Wed Feb 11, 2009 1:50 pm
Posts: 431
Location: Saint Louis
mcbrat wrote:
well, it's been a nicely trouble free first 1000 miles... though it does seem to have developed a pretty good oil leak... one of the PCV tubes has a crack at the base (drivers side vc) got a new one coming to fix that, but haven't gotten under it yet to really see where it's coming from....

it is however an absolute blast to drive...
...
I found a good mug to replace the silencer, but I want to get my gauges in first before I start tweaking stuff :)


Common oil leaks (as you probably already know) are valve covers and cam seals. And you're bound to have some cracked and leaking vacuum hoses, at this age.

Personally, I'd keep the stock intake, as I've chosen to do on both of my 1st. Gen turbos.

Of course it's a blast to drive! I love taking the SS down a twisty road, shifting between 2nd. and 3rd. keeping the revs right in the power band. Pulls nicely, doesn't it?

Keep an eye on the upper coolant reservoir tank. They get brittle and the hose nipples tend to break easily.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 34 posts ]  Go to page Previous  1, 2, 3

All times are UTC - 8 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Fatal: Not able to open ./cache/data_global.php