The Electra Forums

Guitar Talk about Electra and other vintage imported guitars
Home
Index of Models
The Electra Forums
PM Inbox
It is currently Mon Oct 23, 2017 7:55 pm

All times are UTC - 8 hours




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: x150 active
PostPosted: Wed Sep 25, 2013 1:48 pm 
Offline

Joined: Wed Feb 13, 2013 4:56 pm
Posts: 43
HHHHelp.....need a mini switch for active circuit for 150...looks like 4 pole... there are 12 legs on switch...i have the wiring positions but need to know configuration of switch..single throw etc...


Top
 Profile  
 
 Post subject: Re: x150 active
PostPosted: Thu Sep 26, 2013 7:13 am 
Offline

Joined: Wed Feb 11, 2009 1:50 pm
Posts: 431
Location: Saint Louis
4PDT, sometimes shown as 4P2T

Four poles, double throw. I've never had one in my hands, so I'm not sure if it's a two position (on-none-on) or three position.

This might be a good candidate if the original is two position:

http://www.parts-express.com/pe/showdet ... mpaign=pla


Top
 Profile  
 
 Post subject: Re: x150 active
PostPosted: Thu Sep 26, 2013 8:18 am 
Offline
User avatar

Joined: Thu Feb 07, 2008 5:52 am
Posts: 1924
Location: Ann Arbor, Michigan
You'd be better off just leaving it on all the time and using the Active Volume. Take it from possibly the only person on Earth crazy enough to have owned all five Powered-EQ models. The batteries in my X250 lasted over two years and it gets a ton of play time, including being one of the guitars I use Live.

The Active circuit makes a very noticeable POP when engaged, and that 12 pin switch is going to be an afternoon cuss-fest when you get around to trying to replace it. The batteries are only draining when the guitar is plugged in, like a stomp box, and as I said they last a good long time. See my X200 video if you want to see how I use the Active Volume to go from clear to crunch to meltdown. Good luck, Mike.

_________________
Electra Guitar Videos ===> http://www.youtube.com/user/mjm33mjm?feature=watch


Top
 Profile  
 
 Post subject: Re: x150 active
PostPosted: Fri Sep 27, 2013 6:43 am 
Offline

Joined: Wed Feb 13, 2013 4:56 pm
Posts: 43
thanks for the info....never new about the pop...dont want that....old switch has broken toggle but was making a noise....i figured bad switch...... thought about disconnecting and using as x149.....however i discovered a factory solder flow problem on active board that had 2 pins shorted ...removed excess and sounds good now...thanks again for info....and hey Mike...your videos and demos are excellent...i watch them all the time


Top
 Profile  
 
 Post subject: Re: x150 active
PostPosted: Thu Oct 03, 2013 12:33 pm 
Offline
User avatar

Joined: Thu Feb 07, 2008 5:52 am
Posts: 1924
Location: Ann Arbor, Michigan
Thanks man, I appreciate the views on the Youtube channel. Cheers, Mike.

_________________
Electra Guitar Videos ===> http://www.youtube.com/user/mjm33mjm?feature=watch


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC - 8 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Fatal: Not able to open ./cache/data_global.php