The Electra Forums

Guitar Talk about Electra and other vintage imported guitars
Index of Models
The Electra Forums
PM Inbox
It is currently Sat Mar 24, 2018 10:03 am

All times are UTC - 8 hours

Post new topic Reply to topic  [ 1 post ] 
Author Message
PostPosted: Wed Dec 10, 2014 9:12 pm 

Joined: Wed Dec 10, 2014 8:54 pm
Posts: 6
Hey everyone. Just bought an Electra X230 on eBay. Never played one. Never actually heard of them until I started researching the whole "lawsuit" guitar world. Since I'm not familiar at all with them I wanted to ask a question about the pickups. The guitar still has the original 5 position rotary switch and I was noticing that the sound was pretty thin and quiet on all of the settings except for positions 2 and 3. Position 1 sounds OK but not as good as the other couple. Just wondering if this is usually the case or if there may be something going on with one of the pickups. I was planning on taking it in to a local shop here in Seattle to have it set-up and generally looked at/cleaned up but this issue was the first thing that came up when I started playing it. It also seemed like the "lead color switch" didn't seem to change the sound much at all. Wonder if these two things might be related. Hope someone can shed some light here. Thanks!

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC - 8 hours

Who is online

Users browsing this forum: Bing [Bot] and 9 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group