The Electra Forums

Guitar Talk about Electra and other vintage imported guitars
Home
Index of Models
The Electra Forums
PM Inbox
It is currently Fri Dec 15, 2017 8:12 am

All times are UTC - 8 hours




Post new topic Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Tue Mar 17, 2015 11:51 pm 
Offline

Joined: Sun Sep 19, 2010 1:14 am
Posts: 262
Got an X710 last week and discovered the 9v battery clip was missing, checked the diagrams and read thorny's post (thank you!!!!). I think I wired the clip right tonight?? -- red wire hot, black ground to jack (to turn on/off right?) -- and everything seemed to mostly work but what a strange sound!! Actually quite cool cranked with subharmonic generated -- but so muffled at lesser volume -- well I had just read thorny's 50k post and lo and behold.....I have a question tho -- the ground wire connecting the back of pot cases has a leg coming off at right angles between the vol & tone pots and it is not connected, where does it go please?
I will get 500k pots tomorrow....of course, I plan to put it on eBay after fixing it, if it sounds as good as it plays it will be quite nice -- and also of course (for the newer guys) if anyone here is interested pm me...I'm a sucker for forum members lol (it's just Electra love)
BTW if you know anyone looking for really good acoustic, I have a 1954 J-50 on the %#@& 'Bay and could do quite a bit better on it to a good home -- it's pretty exceptional as it's crack-free in addition to sounding like heaven (pawn shop find of a lifetime but that's another story)

Regards to all, you folks are the best......


Top
 Profile  
 
PostPosted: Wed Mar 18, 2015 8:22 am 
Offline
User avatar

Joined: Thu May 03, 2007 9:32 am
Posts: 1024
Location: NYC
A picture would help. Is the tone pot grounded. It could be they ran the ground from the volume to the tone and on to the ground.


Top
 Profile  
 
PostPosted: Wed Mar 18, 2015 1:38 pm 
Offline
User avatar

Joined: Thu Feb 07, 2008 5:52 am
Posts: 1924
Location: Ann Arbor, Michigan
Here is an entire thread about the Super Charger kit, but it also has three pictures of different control cavities for you to compare to your own. The MPC thread (sticky at the top of this Repair section) has a wiring diagram for the MPC circuit also:

viewtopic.php?f=15&t=4682

Best of luck, Mike.

_________________
Electra Guitar Videos ===> http://www.youtube.com/user/mjm33mjm?feature=watch


Top
 Profile  
 
PostPosted: Wed Mar 18, 2015 4:35 pm 
Offline

Joined: Sun Sep 19, 2010 1:14 am
Posts: 262
Awesome, more info --- duh, ground in question goes under cover to shielding (hook end has broken off) -- just got two 500k pots in (but darn one has threads too short so I'll have to search for another -- will 250k work for the tone pot?) and had to check it out to see if it sounds better (don't even have grounds connected to pots yet) and I am amazed -- now this guitar is inspiring, my 2 minute check turned into an hour lol......it's already about the best sounding Electra I've played -- I'll get another pot in & finish up but I sure do like this one
Thanks for the input :up: :up: :up:


Top
 Profile  
 
PostPosted: Sat Mar 21, 2015 10:11 pm 
Offline

Joined: Sun Sep 19, 2010 1:14 am
Posts: 262
All done and amazingly everything works..this is a blast to play :love: Thanks, y'all!!!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC - 8 hours


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Fatal: Not able to open ./cache/data_global.php