The Electra Forums

Guitar Talk about Electra and other vintage imported guitars
Home
Index of Models
The Electra Forums
PM Inbox
It is currently Thu Dec 14, 2017 7:27 am

All times are UTC - 8 hours




Post new topic Reply to topic  [ 10 posts ] 
Author Message
PostPosted: Thu Mar 20, 2014 9:52 am 
Offline

Joined: Thu Mar 20, 2014 9:42 am
Posts: 4
Howdy y'all! I just picked up the beaut below (w/ case, 1 module and paperwork). I'm loving everything about her but the pickups--they just sound muddy and blah. Is this par for the course with these guys? Would rewiring to Steve Higdons MPC diagram help, or do I want to both rewire and replace the pickups?

Thanks all!
Image


Top
 Profile  
 
PostPosted: Thu Mar 20, 2014 10:14 am 
Offline
User avatar

Joined: Thu May 03, 2007 9:32 am
Posts: 1024
Location: NYC
There have been a few threads about some of the MPC models going out with a 500mf capacitor when they should have had a 50 mf. Check to see it this is the case with yours.


Top
 Profile  
 
PostPosted: Thu Mar 20, 2014 11:11 am 
Offline
User avatar

Joined: Mon Jul 26, 2010 10:23 am
Posts: 971
Location: Oxford, MI
If it is not the capacitor problem on yours and you decide to swap out pickups, try to hold on to the originals. It never hurts the value to have original parts if you ever decide to sell it.

_________________
"This is the way that pop ends, Not with a BANG but with a box set whose fourth disc you never get around to playingā€¯ - Simon Reynolds

"My guitar wants to kill your Mama" - Frank Zappa & The Mothers of Invention


Top
 Profile  
 
PostPosted: Thu Mar 20, 2014 12:22 pm 
Offline
User avatar

Joined: Mon Oct 27, 2008 7:10 pm
Posts: 3017
Location: Tifton, Ga USA
The muddy tones are a good indicator of the incorrect pots being installed so check them for certain before you re wire and also remove all mac modules and see if the tone gets better.

_________________
Always give thanks for everyday, It may be your last so Rock On Semper Fi!!


Top
 Profile  
 
PostPosted: Thu Mar 20, 2014 12:49 pm 
Offline

Joined: Thu Mar 20, 2014 9:42 am
Posts: 4
Thanks guys! 1 PU is already swapped (original is in the case). The Muddiness/blah happens w/ the module it came with (Phaser) removed.

I'll look into the parts values concerns!


Top
 Profile  
 
PostPosted: Fri Mar 21, 2014 4:28 am 
Offline
User avatar

Joined: Fri Feb 11, 2011 1:19 pm
Posts: 676
Location: Harrisburg, Pennsylvania
Does your tone pot work? It's the second knob. My MPC Electra X330 did that, the tone pot was dirty and made it stick to fully "off" if that makes sense to you. Try turning it and see what it does.

Check your pots. You should have two that read 500k and two that read 150k. If you have two that read 50k, then they need replaced with 500k pots.

Do these things and get back to us soon.

_________________
"GREAT Googiley moogilie Jack...jumpin jehosephat, hot dang and all".
- jdwhealton


Top
 Profile  
 
PostPosted: Fri Mar 21, 2014 4:31 am 
Offline
User avatar

Joined: Fri Feb 11, 2011 1:19 pm
Posts: 676
Location: Harrisburg, Pennsylvania
For the record, my X720 Outlaw is a very open, full sounding guitar. No muddy in the least. So the tone knob or pots may be to blame. Photo your electronics cavity and post it on here.

_________________
"GREAT Googiley moogilie Jack...jumpin jehosephat, hot dang and all".
- jdwhealton


Top
 Profile  
 
PostPosted: Fri Mar 21, 2014 7:36 am 
Offline

Joined: Thu Mar 20, 2014 9:42 am
Posts: 4
Will do--thanks y'all!


Top
 Profile  
 
PostPosted: Fri Mar 28, 2014 5:18 pm 
Offline

Joined: Thu Mar 20, 2014 9:42 am
Posts: 4
Yup--50k pots! My Tech is going to be replacing them and wiring in the Stock bridge pickup, as well. Can't wait to hear her the way she is meant to sound! Thanks again for all the help, y'all.


Top
 Profile  
 
PostPosted: Mon Mar 31, 2014 4:30 am 
Offline
User avatar

Joined: Fri Feb 11, 2011 1:19 pm
Posts: 676
Location: Harrisburg, Pennsylvania
:up: Others have said it's like taking the blanket off. You'll notice it!

_________________
"GREAT Googiley moogilie Jack...jumpin jehosephat, hot dang and all".
- jdwhealton


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 

All times are UTC - 8 hours


Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Fatal: Not able to open ./cache/data_global.php